Partial Outage
Resolved

This incident has been resolved. All systems are now operating normally.

Mon, Oct 20, 2025, 08:55 PM
(6 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved. All systems are now operating normally.

Mon, Oct 20, 2025, 08:55 PM

Identified

Basewell is currently seeing partial connectivity outages from upstream providers. We are currently monitoring the situation and will continue to update the status page.

Mon, Oct 20, 2025, 05:38 PM(3 hours earlier)